Mini-projektet som tog en månad ("hårddisk" till Amiga 1000)

Diskussioner om Amiga

Moderatorer: Fanta_gbg, stonan, Zlasher

Mini-projektet som tog en månad ("hårddisk" till Amiga 1000)

Inläggav herdware » 28 september 2019, 11:49

Ville ju ha en hårddisk till min Amiga 1000. Tyvärr är de både ovanliga och väldigt dyra när de dyker upp på ebay. Mindes att jag sett drivrutin och bygginstruktion för att koppla en parallellports Zip-drive till amiga på aminet. Det går inte koppla in en Zip direkt till Amigans parallellport då Commodore i sin outgrundliga visdom inte gjorde parallellporten IEEE 1284. För att göra det ännu värre är Amiga 1000-porten annorlunda än på alla andra Amigor. Se http://www.l8r.net/technical/t-amigaparallel.shtml Observera att pin 14 är jord på A1000 men +5V på alla andra! Pin 23 är +5V på A1000 men jord på övriga! Danger Will Robinson, danger. Dessutom är det olika kön på porten på A1000 kontra resten.

Planen var att köpa en kabel från en tjeckisk snubbe på amibay och sen bygga om den till A1000. Åkte på patrull direkt då jag blev instabannad från amibay när jag reggade mig. "Något var fel med uppgifterna" och inga mail till amibay har besvarats.
Det finns bygginstruktioner för två olika kablar i arkivet. En buffrad och en obuffrad.
Jaha, får väl bygga en egen då :( Köpte grejer på Kjell och svängde ihop min egen kabel. Laddade ner ppazip.lha från aminet (version 0.8, det är viktigt att notera). Naturligtvis(?) fungerade det inte.
Planen var fortfarande samma - testa på A500 (WB 1.3) för att sedan köra på A1000. Amigan hänger sig nästan direkt efter mount zip0:.
Kontrollerar kabeln flera gånger utan att hitta några fel.

Tack vara attle på safir får jag emailadressen till snubben på amibay som tillverkar kablarna. Beställer en (och lite annat smått och gott). En vecka senare har jag kabeln och testar igen. Hänger sig fortfarande! Mailar killen och då kommer det fram att version 0.7 är den sista som fungerar med Workbench <2.0. Detta står inte i dokumentationen till ppazip! Det hade varit kul att veta innan jag började detta projekt. Version 0.7 verkar vara bortblåst från internets men Pavel mailar arkivet plus två bootdisketter (1.3 och 2.x) nu hänger det sig inte längre! 0.7 och tidigare stödjer inte scsidirect så hdtoolbox och liknande fungerar inte på den. Fick formatera från cli men nu har jag äntligen en 100MB stor "hårddisk" kopplad till min A500.
Pavels kabel fungerar men inte min till en början, någonstans på vägen har en ledare gått av till kabeln som går till joystickporten vilket nu är fixat.

Nästa steg är förstås att testa på A1000. Sagt och gjort. Kopplar in min kabel (som byggdes A1000-kompatibel från början) och testar - fungerar inte! Inte ett liv ur zip:en.
Kontrollerar kabeln förstås. Inga fel.
Här ser jag två möjligheter:
1) Min A1000 är defekt
2) Den behöver en buffrad kabel.
Har ingen 7407 hemma så jag bordlägger projektet.

Någon vecka senare har jag införskaffat det jag behöver för att bygga om kabeln. Valde nog fel väg att gå här så det blev väldigt pilligt att få ihop, but hey.
Igår lyckades jag för första gången få det att funka!
Här är en youtube-video när den "autobootar" Workbench 1.3. Dvs tidigt i s-s monteras zip0: och sedan assignas allt över till den och booten fortsätter från den.
https://www.youtube.com/watch?v=OVWsj2CoBjI

Första försöket att registrera mig på amibay 24/8, första boot på Amiga 1000 27/9.
Användarvisningsbild
herdware
Stormästare
Stormästare
 
Inlägg: 1367
Blev medlem: 6 mars 2008, 21:07
Ort: Nordvästra Småland

Re: Mini-projektet som tog en månad ("hårddisk" till Amiga 1000)

Inläggav herdware » 28 september 2019, 11:56

Hur snabbt går det då? Ja det är ju inget fartmonster direkt.
CAM00858.jpg

Det är dock ca 10k/s snabbare än på min Amiga 500.
Observera att denna lösning använder både parallellporten och andra joystickporten vilket begränsar en hel del. Inget man kör whdload från precis.
Passthrough-porten till skrivaren fungerar inte heller på Amigan enligt dokumentationen.
Det funkar bara med original ZIP 100 för parellellporten, inte ZIP+ och ZIP 250 som kom senare.
Den kan tydligen läsa korrupt data ibland, se dokumentationen för mer info.

Länk till ppazip 0.8:
http://aminet.net/package/docs/hard/ppazip

Försökte ladda upp ppazip 0.7 som en bilaga om någon annan ville prova men forumet tillåter visst inte lha som bilaga.

CAM00860.jpg

Inget bygge att vara stolt över direkt...
Användarvisningsbild
herdware
Stormästare
Stormästare
 
Inlägg: 1367
Blev medlem: 6 mars 2008, 21:07
Ort: Nordvästra Småland

Re: Mini-projektet som tog en månad ("hårddisk" till Amiga 1000)

Inläggav bjonte » 28 september 2019, 12:39

Vilken resa och vilket bök!
Användarvisningsbild
bjonte
Stormästare
Stormästare
 
Inlägg: 1692
Blev medlem: 17 april 2006, 23:12

Re: Mini-projektet som tog en månad ("hårddisk" till Amiga 1000)

Inläggav herdware » 28 september 2019, 12:43

Jodu, inget är enkelt när man har med en Amiga 1000 att göra...

Förresten, är det någon som har en USB zipdrive över?
Användarvisningsbild
herdware
Stormästare
Stormästare
 
Inlägg: 1367
Blev medlem: 6 mars 2008, 21:07
Ort: Nordvästra Småland

Re: Mini-projektet som tog en månad ("hårddisk" till Amiga 1000)

Inläggav bjonte » 28 september 2019, 13:45

Jag har en kompis som har en Z100atapi som du kan få, men det är IDE för intern montering.
Användarvisningsbild
bjonte
Stormästare
Stormästare
 
Inlägg: 1692
Blev medlem: 17 april 2006, 23:12

Re: Mini-projektet som tog en månad ("hårddisk" till Amiga 1000)

Inläggav herdware » 28 september 2019, 14:11

Har en intern ATAPI liggandes någonstans men det är just USB jag är ute efter (och kanske en till parallell eller SCSI).

EDIT: Gjorde en zip-fil med lha-arkivet eftersom forumet inte tillåter lha som bilaga.
Bilagor
ppazip_v0_7.zip
(77.19 KiB) Nerladdad 6 gånger
Användarvisningsbild
herdware
Stormästare
Stormästare
 
Inlägg: 1367
Blev medlem: 6 mars 2008, 21:07
Ort: Nordvästra Småland

Re: Mini-projektet som tog en månad ("hårddisk" till Amiga 1000)

Inläggav herdware » 29 september 2019, 14:38

Efter en del pill lyckades jag installera Workbench 3.1 på en annan skiva. Gjorde en likvärdig bootdisk för 3.1 som lämnar över till Zipen tidigt och bootar resten från den.
Twinkick softkickar 3.1 in i fastram.
https://youtu.be/68wQyNzJAJs

EDIT:
Lite hastighetsjämförelser
Amiga 500 med WB 1.3, 512k chip och 512k slow
Amiga 1000 med 512k chip och 8mb fast
ppazip 0.7 på WB 1.3 och ppazip 0.8 på WB3.x

A500: 92k/s
A1000 WB 1.3: 102k/s
A1000 WB 3.1: 96k/s
A1000 WB 3.1.4: 99k/s
Detta enligt sysinfo.

Ska testa att installera 3.1.4 när jag får tag på fler zip-diskar.
Användarvisningsbild
herdware
Stormästare
Stormästare
 
Inlägg: 1367
Blev medlem: 6 mars 2008, 21:07
Ort: Nordvästra Småland

Re: Mini-projektet som tog en månad ("hårddisk" till Amiga 1000)

Inläggav herdware » 3 oktober 2019, 21:10

Bara en uppdatering. Det fungerar inte att softkicka 3.1 med twinkick och sedan installera 3.1.4. När 3.1.4 kör sin romupdate i s-s så blir det fel och plötsligt stirrar man på kickstart 1.3-skärmen.
Så vill man köra 3.1.4 på en Amiga 1000 så är det till att sätta in en kickrom i maskinen. Såvida inte författaren till twinkick får för sig att uppdatera det för 3.1.4 förstås.
Användarvisningsbild
herdware
Stormästare
Stormästare
 
Inlägg: 1367
Blev medlem: 6 mars 2008, 21:07
Ort: Nordvästra Småland


Återgå till Amiga

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 2 gäster

Banners

BOA Japon Mediapalatset Nostalgibutiken
Quartex Retro Overlays Retroplay Spel och sånt
Super Motaro Söders Serie & Skivhandel vintagegames.se RG 2016
cron